NaviUser - Das GPS Forum für Einsteiger und Experten

Zurück   NaviUser > GPS Praxis und weitere GPS Geräte > Magellan > Meridian

Hinweise

 
 
Themen-Optionen Ansicht
  #1  
Alt 05.12.2011, 16:26
rk98 ist offline rk98
NaviUser
 
Registriert seit: 03.11.2010
Beiträge: 49
Reparatur eines MeriPlat

Hallo,

da es hier in diesem Bereich eher ruhig ist, will ich einfach mal berichten, wie sich mein Platinum verabschiedet hat und wie ich ihm wieder Leben eingehaucht habe :-) Es könnte vielleicht einem Anderen Ansporn sein sein Meridian ebenso "wachzuküssen".

Ich nutze mein MeriPlat fast ausschließlich beim Moppedfahren.

Vor einigen Jahren hatte es zweimal eine Zeit lang einen Fehler, der zunächst aussah, wie wenn die Antenne einen Wackelkontakt hätte. Hatte sie aber nicht. Optisch war nichts zu erkennen, nachlöten der Antennenfolie an der Platine brachte auch keine Besserung, lediglich das Abwarten brachte eine "Reparatur". Soll heißen, daß ich das Gerät als defekt eingestuft in die Ecke legte und mich einige Zeit später drum kümmerte. AFAIR dreimal fand so ein "Defekt-Spiel" statt und jedesmal tat das Gerät nach einiger Zeit wieder, ohne daß eine zielgerichtete Reparatur Erfolg versprochen hätte. Beim dritten Mal gab es ebenso scheinbare Empfangsprobleme, aber weiterhin noch andere merkwürdige Effekte in der Software. Nie war etwas reproduzierbar, was eine Analyse nahezu unmöglich machte.

Ich nehme an, daß es sich um Software-Fehler handelte, die aufgrund von irgendwelchen Berechnungen (Underflow, Overflow, also Verlassen des zulässigen Wertebereichs des Algorithmus) irgendwann wieder in einen gültigen Bereich kamen. Oder, wenn ich Thales das unterstelle, was bei manchen Duckerherstellern schon längere Zeit bewiesen ist: das Vortäuschen eines Hardware-Fehlers mit Hilfe von Software, um den Kunden zum Neukauf zu motivieren. Dies kam im Fall vom MeriPlat über meinen Anfangsverdacht nicht hinaus. Die Fehler äußerten sich in den 2 Fällen der scheinbaren Empfangsprobleme so, daß im Laufe des Empfangs die "berechnete" Koordinate in Einzelfällen oder über einen längeren Zeitraum hinweg um viele km, teils sogar mehrere 1000km falsch lag. Es konnte sein, daß der Tracklog das Bild eines Weihnachtssterns (in 2D) abgab. Im Zentrum der tatsächliche Ort oder die Gegend, in der das Gerät bewegt wurde, und dann die Ausreißer um einige 100km in alle Richtungen. In 3D wurden teils abenteuerliche Höhen angezeigt bzw. aufgezeichnet. Ein konkretes Muster war nie feststellbar, eine konstante Abweichung ebensowenig. Daher der Verdacht auf Antennenproblem. Wie geschrieben "beruhigte" sich das Gerät jeweils nach ein paar Tagen und Wochen und empfing dann wieder mit der gewohnten Genauigkeit.


Auf Reise auf den großen Moppeds ist es im Tankrucksack oben im Kartenfach untergebracht. Dort hat es guten Empfang, ist gut geschützt vor Vibrationen, leidet aber im Sommer unter den hohen Temperaturen. Ich hatte es mehrfach in sehr warmen Gegenden, daß es sich ab einer Innentemperatur von rund 65 - 67 Grad abgeschaltet hatte. Das verlief auf etlichen Reisen problemlos. Da hieß es Gerät abkühlen und weiter geht's :-) Nicht so bei der letzten großen Reise, als es sich schon etwas vor der bekannten Temperatur abschaltete, aber danach nicht mehr richtig zum Leben erwachte. Also großer Fehler #4 :-(

Es hatte einerseits seine Konfigurationsdaten und seinen gesamten Speicherinhalt verloren, also Tracklog, Waypoints, usw. Das war neu, denn das gab es bei früheren automatischen Abschaltvorgängen nicht, und auch bei den temporären Defekten war solch ein Datenverlust nie zu beklagen

In dieser Situation startete ich das Gerät nach Abkühlen, später nach einer mehrtägigen Pause ganz ohne Akkus ganz normal wieder. Es fragte mich nach den initialen Einstellungen, also Sprache, Gegend des Einsatzes (Kontinent, Land, Datum, Uhrzeit). Ich konnte daraufhin ins MENU und meine gewohnten Einstellungen vornehmen, bis es irgendwann einfach abstürzte, sich gar nicht mehr bedienen ließ und teils per Akku-Entfernen abgeschaltet werden mußte. Den Griff GOTO-ESC-ENTER kannte ich unterwegs nicht. Nein, ich hatte die Beschreibung der HiddenCommands nicht mitgenommen. Danach begann das Spiel jeweils von vorne. Da nach einem Neustart aus dem Werkszustand der Tastaturpiepser eingeschaltet ist, konnte passieren, daß das Gerät mit eingeschaltetem Piepser abstürzte und munter vor sich hinpfiff :-(

Vor ein paar Tagen gab ich dem Gerät nochmal eine Chance :-) Die hat einen einleuchtenden Grund: es gibt für mich kein passendes Ersatzgerät, denn die Funktionalität vom MeriPlat entspricht zu 100% dem, was ich gerne haben möchte, und keine einzige Funktion mehr. Genau das gibt es seit Jahren nicht auf dem Markt. Also probierte ich systematisch. Immer nach einigen Minuten Laufzeit stürzte das Gerät ab. Mehr war nicht zu erkennen. Legte ich es nur an eine Stelle mit Empfang, dann war es nach einigen Minuten genauso tot wie wenn ich versuchte meine Basiseinstellungen vorzunehmen. Ok, ein Firmware-Update auf die Version 5.4.1 war fällig. Meine Hoffnung: 1. vielleicht ein bekannter, wenn auch seltener Fehler, der dann behoben wäre (vergebliche Hoffnung), 2. Neuprogrammierung des Flash-ROMs mit der Firmware und dadurch ggf. Ausgleich eines Hardware-Fehlers, z.B. gekipptes Bit im Flash-ROM (ebenso vergebliche Hoffnung).

Aber im Laufe des Tests ließ sich das Schema des Zeitpunkts des Absturzes etwas einkreisen: meist in dem Moment, wo die Empfangssituation derart war, daß das Gerät den ungefähren Standort erkannte. Da will es auf die Kartendarstellung umschalten, unten wird "Loading ..." eingeblendet, also wird offensichtlich die Basemap gelesen. Andere Karten hatte ich noch nie drin. Nur, sagte ich mir als Auch-Software-Entwickler, kann beim Lesen der Kartendaten eigentlich(!) kein Abstuz passieren, da die einzelnen Datensätze beim Einlesen geprüft werden müßten (Syntax, Plausibilität, usw.). Ich spielte trotzdem eine neue Basemap auf, dieselbe "EU-Land" wie vorher auch, und seither geht das Gerät wieder.

These: aufgrund irgendwelcher Umstände (Temperatur, "kosmische Strahlung" ;-) ) ist im Flash-ROM der Basemap mind. 1 bit gekippt, das die Einleseprozedur derart durcheinander brachte, daß die ganze Firmware regelmäßig abgestürzt ist.

Problem:
- So ein Bit, oder auch mehrere, kann im FLash-ROM unter den rauhen Bedingungen schon mal kippen. Es sollte nicht vorkommen, aber es ist passiert.
- Die Software hat arge Probleme bei den Einlese-Routinen hinsichtlich Prüfungen. Nicht nur ein Problem, sondern ein unverzeihlicher Fehler!

Fazit: Die Hardware der Meridian-Baureihe war und ist robust, wenn ich von dem ausgehe, was mein Gerät bisher so alles mitgemacht hat. Die Software ist dagegen von einer ordentlichen Weiterentwicklung und Fehlerbereinigung weitestgehend verschont geblieben. Leider. Für zukünftige Reisen ist somit auch klar, was ich mitnehmen werde: die HiddenMenus in Papierform und die Firmware sowie die Basemap auf der Speicherkarte für eine Notfallinstallation. Und: ich reise zwar in Wüsten, aber niemals nur alleine mit einem MeriPlat. Mind. ein anderer GPS-Empfänger ist mit dabei, meist ein altes eTrex Venture bzw. die Geräte der Mitreisenden. Karten auf Papier sowieso.


Gruß, Ralf
Mit Zitat antworten
 

Themen-Optionen
Ansicht

Forumregeln
Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.



Alle Zeitangaben in GMT +2. Es ist jetzt 19:48 Uhr.


Powered by vBulletin® Version 3.8.4 (Deutsch)
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Template-Modifikationen durch TMS
© 2010 NaviUser KL