NaviUser - Das GPS Forum für Einsteiger und Experten

Zurück   NaviUser > Garmin Geräte > Oregon Serie

Hinweise

Antwort
 
Themen-Optionen Ansicht
  #1  
Alt 01.07.2015, 20:55
AndreasL ist offline AndreasL
Admin
 
Registriert seit: 20.11.2008
Ort: Berlin
Beiträge: 2.733
Ausrufezeichen Gerät Formatiert, Backup restauriert, nichts geht (Lösung)

Ich hatte das Vergnügen mich um ein Oregon 450 zu kümmern. Das wurde an einen Apple gesteckt und dann versehentlich dort der interne Speicher formatiert... passiert. Der Besitzer hat aber ein Dateibackup des gesamten Geräts auf DVD. Sehr Löblich!

Was liegt also näher als alles zurück zu kopieren? Das Gerät startet trotz Formatierung noch immer auf den Desktop. Der 2GB Flash Speicher ist segmentiert und enthält eine nicht sichtbare Partion für die Firmware. Der Restliche Speicher, ca 1,8GB, ist dann als User-Space verfügbar. Allerdings meldet sich das Gerät nach dem starten nur noch in englisch und wenn man versucht die Sprache umzustellen kommt nur 'missing language'.

Auch wird das Gerät am PC ohne weiteres nicht mehr als USB Gerät erkannt. Man kann zwar den Datenmodus auf Spanner setzen und kann dann das Gerät über Treiber ansprechen aber der Versuch da was drauf zu schreiben (z.B. mit dem Webupdater) scheitert. Er kann nicht in den Speicher schreiben.

Eine Lösung dafür im Web zu finden ist sehr schwer. Der Wikispace Account zum 450'er ist erloschen und so führen 90% der Treffer ins Leere. So ist erst mal Experimentieren angesagt um zu sehen, woran das liegt.

Also das Gerät in den USB Modus zwingen: Akku raus, Einschaltknopf halten, Kabel ran, 30 Sekunden warten bis sich der USB Modus meldet. Hier kann man nun auf das Laufwerk zugreifen und das Backup restaurieren. Na, das klingt doch schon mal gut, denkt man sich .... alles erledigt?

Die Überraschung erfolgt beim nächsten Test... Es hat sich NICHTS geändert. Das Gerät ist noch immer nicht konfigurierbar. Auch restaurierte Karten werden nicht angezeigt

Das geht offenbar vielen so und letztendlich schicken alle das Gerät zu Garmin ein und bezahlen viel Geld für Reparatur oder Tausch. Das muss aber nicht sein, denn der Hintergrund ist simpel! Es liegt daran wie das Gerät formatiert wird. Ich habe einen Artikel bei Groundspeak gefunden, der das erklärt: http://forums.groundspeak.com/GC/ind...owtopic=311168

Also Linux Laptop angeworfen (Ubuntu Live DVD geht auch). Oregon ohne Akkus in den USB Modus gezwungen, gparted installiert und mit sudo gparted als Admin gestartet. Jetzt in gparted oben rechts das Device auf das angeschlossene Garmin Gerät umstellen. Bei mir war es /dev/sdb. Hier sieht man schon was los ist.

Das Device dismounten, die Partion löschen. Submit. Jetzt ist es wirklich leer. Dann das Terminal aufrufen und mit sudo mkfs.vfat -I /dev/sdb (so wie gparted es angezeigt hat) eine neue Partion anlegen. Wichtig ist hier das große i .. also -I. Nicht vergessen, Linux und so

Sicher gibt es auch eine Lösung unter anderen Betriebssystem dafür. Ich habe das nur nicht weiter verfolgt weil ich so ans Ziel gekommen bin. Ich könnte mir Vorstellen, das unter Windows das HP USB Formater Tool dabei ganz gute Dienste leisten könnte. Das löscht USB Devices auch zuverlässig.

Jetzt ist das Gerät im Prinzip gut vorbereitet um oben am Anfang des Artikels noch mal zu lesen anzufangen und die Prozedur noch mal zu machen. Wer einen Dateimanager wie Krusader auf Linux hat oder mit dem Desktop klar kommt kann die Dateien vom Backup auch gleich unter Linux zurück kopieren.

Wer kein Backup hat nimmt als nächstes einen Windows PC und lässt das Oregon ganz normal starten. Es sollte sich jetzt einigermaßen normal verhalten und sich auch wieder mit USB ansprechen lasen. Die nächsten Schritte sind dann wie immer Webupdater & Co.

Wenn das Gerät 'Software Missing' meldet oder nur mit einem weißen Bildschirm startet kann man sich bei Perry ein System runter laden (http://gawisp.com/perry/oregon/). Benötigt wird eine Firmware als .gdc (Webupdater File) um sie einfach auf eine micro-SD Card zu packen. Das Oregon macht dann beim nächsten Boot ein Update von SD-Card und sollte wieder laufen.

Happy Recovering.
__________________
biker-reise.de - Reiseberichte und Touren aus Schottland, Frankreich, Slowakei, Alpen, Norwegen und Brandenburg
gpswiki.de - stell dein Wissen bereit
Alle Beiträge stellen meine persönliche Meinung dar, Moderation wird besonders gekennzeichnet
Mit Zitat antworten
  #2  
Alt 01.07.2015, 22:19
Hein-Blöd ist offline Hein-Blöd
Lexikon Autorenteam
 
Registriert seit: 26.11.2008
Ort: Sauerland
Beiträge: 1.002
Das Problem dürfete wohl sein das der MC das Oregon so Formatiert hat das es mit dem neu vorhandenem Dateisystem nicht mehr arbeiten kann.

NEVER JUSE A MC
__________________
Meridian Color, SP c510d, 60csx, Nüvi 765, 62st, Nüvi 3590
Mit Zitat antworten
  #3  
Alt 01.07.2015, 22:50
AndreasL ist offline AndreasL
Admin
 
Registriert seit: 20.11.2008
Ort: Berlin
Beiträge: 2.733
das stimmt so nicht ganz. Der Mac hat ganz richtig schon Fat32 formatiert. Dabei aber eine Partition angelegt die nicht bei Offset0 anfängt. Das war wohl das eigentliche Problem an der Sache. Offenbar greift die Firmware fest auf bestimmte Adressen zu und erwartet das dort bestimmte Dinge liegen. Und wenn dan ein Offset dazu kommt gibt es seltsame Effekte.
__________________
biker-reise.de - Reiseberichte und Touren aus Schottland, Frankreich, Slowakei, Alpen, Norwegen und Brandenburg
gpswiki.de - stell dein Wissen bereit
Alle Beiträge stellen meine persönliche Meinung dar, Moderation wird besonders gekennzeichnet
Mit Zitat antworten
Antwort

Themen-Optionen
Ansicht

Forumregeln
Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.



Alle Zeitangaben in GMT +2. Es ist jetzt 15:47 Uhr.


Powered by vBulletin® Version 3.8.4 (Deutsch)
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Template-Modifikationen durch TMS
© 2010 NaviUser KL